Posts: 2
Joined: Apr 12th 2017 6:41pm
#1 Apr 12th 2017 7:10pm
Hello, so I'm getting this error as stated in the title (Could not connect to phpBB installation [NOT PHPBB ADMIN]).

Here's some background. I switched from a .net to a .com as my primary site some time ago. Everything has been working fine. However, I noticed the links on my post pages "view discussion in thread" (or whatever it says) was still pointing to my old .net website. This was never a problem since everything was redirecting to my .com anyway. But I wanted to see if this could be corrected. I deactivated the plugin, re-activated it, and when I tried to connect it again, I got the error above.

I am running
phpbb 3.0.12
WordPress 4.7.3
BridgeDD Version 1.4.1

I did a quick search and seems my issue was similar to this thread:
viewtopic.php?t=118

Any ideas?
Avatar
Posts: 1450
Joined: Sep 2nd 2012 11:41pm
#2 Apr 12th 2017 9:05pm
That error means you were not logged in as a phpBB admin when BridgeDD attempted to connect the board to WordPress. Since you changed the domain name, the first thing you should do is go to the phpBB ACP and make sure the server and cookie settings have been changed to the new domain name.

You can then go back to the BridgeDD Settings page. When you click the directory name and the board shows up in an IFrame, make sure the board shows that you are logged in. On most installations you can click the login link in the IFrame to log in.

Once you have logged in as an admin, you will be able to save the settings.
Posts: 2
Joined: Apr 12th 2017 6:41pm
#3 Apr 13th 2017 10:45am
Thanks for the quick reply, so awesome of you!

This solution worked exactly as you stated [Solved] !!

Also, if anyone else comes across this: Since I'm running SSL or HTTPS I had to enable "cookie secure" in the cookie settings of phpbb too.

Thanks again for this awesome plugin! It's by far the best solution I've tried.
Avatar
Posts: 1450
Joined: Sep 2nd 2012 11:41pm
#4 Apr 13th 2017 12:07pm
I'm glad everything is working for you!